Latest version updates:

• Fixing minor in-game issues
• Improving optimization
• New loading screen

Please note that with this update version, we are no longer supporting older Android devices. Here’s more on that:
• We’ll stop supporting devices with old Android versions
• The new minimum required version will be Android 4.4 KitKat
• The new minimum required version for Huawei devices will be Android Lollipop 5.0

You can quickly check your version:
Go to “Settings” and then click “About Device”.